added config parser & incoming connection handler
[NextIRCd.git] / src / Makefile.am
index 2f259ff6d4fa258773404b38f6c001fcb5733c40..976d0393e41984e89a6de33d697fe05687c67ff8 100644 (file)
@@ -1,3 +1,20 @@
 ##Process this file with automake to create Makefile.in
 ACLOCAL_AMFLAGS = -I m4
 SUBDIRS = IOHandler IOHandler++ IOHandler_test
+
+noinst_PROGRAMS = nextircd
+nextircd_LDADD = IOHandler/libiohandler.la
+
+BUILT_SOURCES = version.c
+version.c: checkversion
+checkversion:
+       ./version.sh
+
+nextircd_SOURCES = \
+       version.c \
+       tools.c \
+       config.c \
+       ircd_sock.c \
+       ircd_client.c \
+       main.c
+