[IOMultiplexerV2] use libtool to generate libraries
[NextIRCd.git] / src / IOHandler / Makefile.am
index 7cbb02cdffe7f8c1630086536277f9d4df785978..14edac2ae922a894bdba6416757cdfeb60a185a9 100644 (file)
@@ -1,7 +1,7 @@
 ##Process this file with automake to create Makefile.in
 ACLOCAL_AMFLAGS = -I m4
 
-libiohandler_a_SOURCES = compat/utime.c \
+libiohandler_la_SOURCES = compat/utime.c \
     compat/inet.c \
     IOHandler.c \
     IODNSEngine_cares.c \
@@ -14,6 +14,7 @@ libiohandler_a_SOURCES = compat/utime.c \
     IOGarbageCollector.c \
     IOLog.c \
     IOSockets.c \
+    IOSSLBackend.c \
     IOTimer.c
 
-noinst_LIBRARIES = libiohandler.a
+noinst_LTLIBRARIES = libiohandler.la